Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 24, 2025 - 04:00 UTC
Scheduled
We will be performing scheduled maintenance on the WorkCloud Sync services. During this maintenance window, WorkCloud Sync will be temporarily unavailable.
This maintenance is essential to ensure the readiness of our database infrastructure. We recommend that users plan their activities accordingly to minimize any inconvenience.
We appreciate your understanding and patience as we work to enhance our services. If you have any questions or concerns, please feel free to reach out to our support team at https://saassupportportal.zebra.com/.
Posted Jul 23, 2025 - 18:19 UTC
This scheduled maintenance affected: Zebra Companion (US-Central1), Chat (US-Central1), Push to Talk (PTT) (US-Central1, US-East1, US-West1), To-Dos (US-Central1), Login (US-Central1), Location (US-Central1), Calls(Audio/Video) (US-Central1, US-East1, US-West1), and Forums (US-Central1).